워드프레스 업데이트 오류 : 일부 파일을 복사할 수 없을 것이기에 업데이트를 설치할 수 없습니다. 이는 보통 파일 권한이 일치하지 않기 때문입니다.

워드프레스를 사용하다 보면 플러그인이나 테마를 자주 업데이트 해야 합니다. 하지만 워드프레스 업데이트 오류가 나타날 경우 이를 제대로 수행할 수 없습니다.

하지만 일부 파일을 복사할 수 없을 것이기에 업데이트를 설치할 수 없습니다. 이는 보통 파일 권한이 일치하지 않기 때문입니다. 라는 오류가 출력되며 업데이트가 완료되지 않는 경우가 있습니다.

일단 워드프레스가 설치된 루트 폴더로 접속하여 wp-content 경로까지 접속합니다.

접속 후 문제가 되는 폴더의 권한을 변경해줍니다. 플러그인의 경우에는 wp-contents 내 plugin 폴더에 위치하고 있으니 권한을 변경해주겠습니다.

chmod -R 777 plugins

워드프레스 업데이트 오류가 없어지고, 플러그인이 정상적으로 업데이트되는 것을 확인할 수 있습니다.


댓글 남기기

%d 블로거가 이것을 좋아합니다: